Inicio > Ubuntu > Aceleracion 3D con ATI + Compiz Fusion

Aceleracion 3D con ATI + Compiz Fusion

El proximo paso que debemos dar es activar la aceleracion 3D en nuestro S.O. Mubutu (=Ubuntu) . La aceleracion 3D es necesaria en particular para los juegos, de los que ya hablare mas adelante pero tambien para ciertas aplicaciones de diseño como Blender 3D. Este “manual” va dirigido a aquellos que poseen una tarjeta grafica ATI. Recientemente aparecieron unos drivers nuevos para estas tarjetas que permiten activar los efectos que podemos hacer en nuestro escritorio con Compiz Fusion, aplicacion de la que tambien hablare pronto. Para que este manual funcione debes de tener habilitados los repositorios(donde estan los archivos en Internet) restringidos. Para habilitarlos ve a Sistema/Administracion/Origenes del software y alli activa el cuadro de Controladores privativos…(restricted). Empecemos pues…

1º:Descarga los drivers de ATI en este enlace. Es necesario tener instalado este paquete linux-restricted-modules, para ello escribe en un terminal:

sudo apt-get install linux-restricted-modules

2º: Si tenias algun driver anterior, realiza las siguientes acciones en el terminal (si no saltate este paso).

sudo apt-get remove xserver-xgl

sudo rm -f /usr/src/fglrx-kernel*.deb

sudo apt-get remove xorg-driver-fglrx

3º: Ahora instala los drivers nuevos. Para ello abre un terminal y escribe:

sudo sh direccion de los drivers

Para introducir la direccion de los drivers hay un truco. Pulsa con el boton derecho del raton en el archivo de los drivers y elige copiar, vete al terminal y pegalos con boton derecho/pegar. De esta forma nos aparecera la direccion de los drivers. Nos aparecera un instalador grafico muy sencillo que es de “siguiente, siguiente, siguiente”

4º: Una vez instalado configuramos el xorg (maneja el tema del video o algo asi…), para que utilice los drivers nuevos. Escribimos:

sudo aticonfig –initial

sudo aticonfig –overlay-type=Xv

5º: Modificamos el archivo xorg.conf para habilitar el AIGLX. Para ello hacemos:

sudo gedit /etc/X11/xorg.conf

Una vez dentro añadimos las siguientes lineas y guardamos:

Section “Extensions”

Option “Composite” “on” Option “Composite” “1”

EndSection

Section “ServerFlags”

Option “AIGLX” “on”

EndSection

6º: Ahora reiniciamos las X-windows (al escribir esto se me quedo bloqueado en una pantalla en negro con 4 o 5 lineas de texto, reinicie a lo bruto y teoricamente funciono; pero yo creo que vale con reiniciar el pc normalmente, asi que pruebalo primero). Escribimos:

sudo /etc/init.d/gdm restart

7º: Ya estamos terminando. Despues de reiniciar edita el archivo “compiz”. Escribe en el terminal:

sudo gedit /usr/bin/compiz

Busca una linea como esta y añade fglrx al final para que quede asi:

# Driver whitelist
WHITELIST=”nvidia intel ati radeon i810 fglrx

Guarda y cierra.

8º: Escribe esto en el terminal:

glxinfo

Si al principio te aparece direct rendering: yes ;bravo!! ya tienes tu aceleracion 3D, si no algo falla.

*Mi tarjeta es una Radeon X1300, si tienes otra y no funciona es porque hay que borrar una parte en el archivo compiz, pero como es una parte diferente para cada tarjeta, comentame que tarjeta es y te dire que tienes que quitar.

Categorías:Ubuntu Etiquetas: , , , , ,
  1. Flavio
    noviembre 2, 2007 a las 1:54 pm

    Exclente. Al fin pude echar a andar la sapphire hd 2600 pro.
    Debo agregar que:
    hay que tener instalado el linux-restricted-modules . Con eso solucione la pnatalla blanca.

    al menos yo cargo estos modulos en el xorg. bno se si es necesario, pero lo herede de antes:

    Section “Module”
    Load “i2c”
    Load “glx”
    Load “dri”
    Load “ddc”
    Load “bitmap”
    Load “extmod”
    Load “freetype”
    Load “int10”
    load “vbe”
    EndSection

    Gracias por el tutorial !!!

  2. jgcp
    noviembre 2, 2007 a las 2:27 pm

    Muchas gracias Flavio no pense en activar luego el compiz. Jeje Ya esta editado.

  3. otakutron
    noviembre 6, 2007 a las 3:54 pm

    Hola muchas gracias por tu Tutorial hice todo al pie de la letra pero al parecer no me funciono, yo acabo de comprar una ATI Sapphire HD 2600 PRO y no me salio el Bravo :S por favor si tienes un poco de tiempo tu ayuda me serviria mucho, esto fue lo que me salio cuando puse glxinfo.

    Saludos y Muchas Gracias!!!

    name of display: :0.0
    Xlib: extension “GLX” missing on display “:0.0”.
    Xlib: extension “GLX” missing on display “:0.0”.
    Xlib: extension “GLX” missing on display “:0.0”.
    Error: couldn’t find RGB GLX visual

    visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
    id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
    ———————————————————————-
    Xlib: extension “GLX” missing on display “:0.0”.
    Xlib: extension “GLX” missing on display “:0.0”.
    0x21 16 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    Xlib: extension “GLX” missing on display “:0.0”.
    Xlib: extension “GLX” missing on display “:0.0”.
    0x39 32 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    Segmentation fault (core dumped)

  4. jgcp
    noviembre 6, 2007 a las 10:33 pm

    Editado Si has hecho copy-paste del codigo que hay que meter en el xorg.conf mira si las comillas son las mismas que en el resto del archivo, a mi la primera vez me paso eso y tarde en darme cuenta. Pruebalo y comenta que tal (Posdata: el bravo no tiene que salirte es una expresion mia… jejeje)

  5. Fabo
    noviembre 24, 2007 a las 1:25 am

    Cuando quiero entrar a sudo gedit /usr/bin/compiz, me dice que no existe, que debo hacer?. Gracias.

  6. jgcp
    noviembre 25, 2007 a las 1:26 pm

    Doy por hecho que utilizas la 7.10 no? Es raro porque lo trae por defecto, buscalo manualmente en el directorio. Voy buscar que puede ser, de todas formas con lo que has hecho, ya tienes aceleracion 3d no?

  7. david
    diciembre 11, 2007 a las 5:48 am

    muy bueno el manual yo tuve que hacer varias cosillas solo y luego me perdi por un rato, al punto de iniciar en modo texto, pero por fin pude lograrlo y lo malo es que segui demasiadas guias pero casulmente ninguna dice que hay que instalar el paquete “linux-restricted-modules” algo que tuve que deducir por mi propia cuenta :S, en fin de ahora en adelante voy a decir que lo saque de este blog😉

  8. Tulon
    diciembre 30, 2007 a las 11:21 am

    Hola!

    Tengo una ati mobility x600, he seguido todo pero cuando llego al glxinfo me sale esto:

    name of display: :0.0
    display: :0 screen: 0
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
    client glx vendor string: SGI
    client glx version string: 1.4
    client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap

    (bueno, esto sigue con cosas similares)

    ¿Alguna idea?

  9. manuel
    enero 28, 2008 a las 3:12 pm

    hice todo lo que dic ahi, pero al momento de reiniciar mi maquina se desconfiguro la resolucion de la pantalla y ahra se ve mas grande todo…que peudo hacer para dejar mi ubuntu como antes…y yo tmb tengo una ati radeon x1300 pro y hasta ahora no puedo hacer funcionar la aceleracion 3d

  10. guillermo
    marzo 20, 2008 a las 7:51 am

    hola disculpa tengo una radeon x1650 y me boto lo siguiente pero auna asi compiz simplemente no funciona :S que debo hacer despues de esto ??

    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
    client glx vendor string: SGI
    client glx version string: 1.4
    client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
    GLX version: 1.2
    GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: Radeon X1650 Series
    OpenGL version string: 2.0.6958 Release
    OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program,
    GL_ARB_fragment_shader, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_occlusion_query, GL_ARB_point_parameters, GL_ARB_point_sprite,
    GL_ARB_shader_objects, GL_ARB_shading_language_100, GL_ARB_shadow,
    GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_float, GL_ARB_texture_mirrored_repeat,
    GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,
    GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_vertex_shader,
    GL_ARB_window_pos, GL_ATI_draw_buffers, GL_ATI_envmap_bumpmap,
    GL_ATI_fragment_shader, GL_ATI_meminfo, GL_ATI_separate_stencil,
    GL_ATI_texture_compression_3dc, GL_ATI_texture_env_combine3,
    GL_ATI_texture_float, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_compiled_vertex_array, GL_EXT_copy_texture,
    GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_object,
    GL_EXT_framebuffer_object, GL_EXT_gpu_program_parameters,
    GL_EXT_multi_draw_arrays, GL_EXT_packed_depth_stencil,
    GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_rescale_normal,
    GL_EXT_secondary_color, GL_EXT_separate_specular_color,
    GL_EXT_shadow_funcs, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texgen_reflection, GL_EXT_texture3D,
    GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod_bias,
    GL_EXT_texture_mirror_clamp, GL_EXT_texture_object,
    GL_EXT_texture_rectangle, GL_EXT_texture_sRGB, GL_EXT_vertex_array,
    GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_texgen_reflection,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod,
    GL_WIN_swap_hint, WGL_EXT_swap_control

  11. jgcp
    marzo 23, 2008 a las 4:28 pm

    Pues suponiendo que ya has editado el archivo compiz. Instala los ultimos drivers de ati si no lo as hecho, y prueba de nuevo. Veo que si tienes aceleracion 3d. Un saludo

  12. Diego
    junio 8, 2008 a las 9:04 am

    Hola:

    Tengo El ubuntu 8.04 y una radeon x1650…con el tutorial, me quedo pegado en una parte:

    sudo aticonfig –initial

    Data incomplete in file /etc/X11/xorg.conf
    Device section “Configured Video Device” must have a Driver line.
    aticonfig: Parsing the configuration file failed.
    The above error messages are reported from XFree86 and may assist you in
    diagnosing the problem with your configuration input file. Try use -f option
    to generate a new configuration file.

    eso dice al tratar de configurara xorg.

    Espero que puedas ayudarme

  13. jgcp
    junio 9, 2008 a las 8:28 am

    Diego por lo que dices es el fichero xorg.conf el que esta mal escrito, si pudieras poner su contenido aqui seria de ayuda para buscar el error. De todas formas parece que en alguna “section” del fichero no existe la linea del driver o esta mal configurado, prueba a instalar de nuevo los drivers de ATI antes de todo.

  14. Guillermo
    julio 6, 2008 a las 12:06 am

    Tengo el mismo problema que Diego, use el comando “sudo aticonfig –initial -f”

    Y me dice que no existe la linea Driver.. como tu decias jgcp.
    Te lo pegare para ver si me ayudas.

    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type “man xorg.conf” at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section “InputDevice”
    Identifier “Generic Keyboard”
    Driver “kbd”
    Option “XkbRules” “xorg”
    Option “XkbModel” “pc105”
    Option “XkbLayout” “es”
    Option “XkbOptions” “lv3:ralt_switch”
    EndSection

    Section “InputDevice”
    Identifier “Configured Mouse”
    Driver “mouse”
    Option “CorePointer”
    EndSection

    Section “Device”
    Identifier “Configured Video Device”
    EndSection

    Section “Monitor”
    Identifier “Configured Monitor”
    EndSection

    Section “Screen”
    Identifier “Default Screen”
    Monitor “Configured Monitor”
    Device “Configured Video Device”
    EndSection

    Section “ServerLayout”
    Identifier “Default Layout”
    Screen “Default Screen”
    EndSection
    Section “Extensions”
    Option “Composite” “Disable”
    Endsection

  15. jgcp
    julio 6, 2008 a las 12:44 pm

    A ver, el archivo xorg.conf se actualiza automaticamente al instalar los drivers de ATI solo que despues a veces hay que tocar ciertas cosas. Segun veo en tu archivo nada ha sido modificado, reinstala los drivers y reinicia. Despues mira el archivo y deberas observar algunos cambios. Este es mi archivo actual con los ultimos drivers de ATI. Deberias ver algo similar en el tuyo una vez instalados los drivers.

    Section “ServerLayout”
    Identifier “aticonfig-Layout[all]”
    screen 0 “aticonfig-Screen[0]-0” 0 0
    EndSection

    Section “Files”
    EndSection

    Section “Module”
    Load “glx”
    EndSection

    Section “ServerFlags”
    Option “AIGLX” “on”
    EndSection

    Section “InputDevice”
    Identifier “Generic Keyboard”
    Driver “kbd”
    Option “XkbRules” “xorg”
    Option “XkbModel” “pc105”
    Option “XkbLayout” “es”
    EndSection

    Section “InputDevice”
    Identifier “Configured Mouse”
    Driver “mouse”
    EndSection

    Section “Monitor”
    Identifier “aticonfig-Monitor[0]-0”
    Option “VendorName” “ATI Proprietary Driver”
    Option “ModelName” “Generic Autodetecting Monitor”
    Option “DPMS” “true”
    EndSection

    Section “Device”
    Identifier “aticonfig-Device[0]-0”
    Driver “fglrx”
    Option “VideoOverlay” “on”
    Option “OpenGLOverlay” “off”
    Busid “PCI:1:0:0”
    EndSection

    Section “Screen”
    Identifier “aticonfig-Screen[0]-0”
    Device “aticonfig-Device[0]-0”
    Monitor “aticonfig-Monitor[0]-0”
    Defaultdepth 24
    SubSection “Display”
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

  16. asak9
    diciembre 14, 2008 a las 6:34 pm

    hola soy medio nuevo con el tema linux, tengo una ati radeon x1650, lo he hecho todo lo escrito, pero no funciona correctamente, creo que sera por ter instalado driver generico, ahora hay un driver nuevo fornecido por ati, para linux, se puede alguien ayudarme se lo agradesco desde ya… mi ubuntu es 8.04 lts… desde ya muchas gracias…

  17. germaine
    mayo 24, 2009 a las 12:48 am

    mi tarjeta es una ati hd 4650..

  18. txantxar
    agosto 12, 2009 a las 5:23 pm

    Hola!
    yo no he conseguido hacerlo. Tengo una ati rage fury pro 128… no se si exiten drivers para esta tarjeta. si alguien sabe cómo solucionarlo se lo agradecería mucho!! gracias!!!!

  19. nesfe
    noviembre 18, 2009 a las 5:04 am

    no lo quise intentar pq no creo sean los controladores para mi tarjeta misma Rage 128 Pro Ultra / Rage 128 Pro II GL mm tengo el driver r128 nativo de ubuntu si me da 3D pero no los efectos visuales Normales.

    supongo que es lo mas que puede vdd.

  20. septiembre 4, 2012 a las 6:29 am

    There’s definately a lot to find out about this topic. I like all the points you’ve made.

  21. septiembre 22, 2012 a las 2:14 pm

    Hey there! I’ve been reading your website for a long time now and finally got the courage to go ahead and give you a shout out from Kingwood Tx! Just wanted to say keep up the fantastic job!

  1. noviembre 26, 2007 a las 2:12 pm

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: